summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorXavier Claessens <xavier.claessens@collabora.com>2020-10-14 17:21:50 -0400
committerXavier Claessens <xavier.claessens@collabora.com>2021-01-20 08:09:14 -0500
commit950b9f5b25843d95c4667ef60038e8d7b476fbb8 (patch)
tree77bca21544d459c3da8a9cf241f9dbbc3244a717 /meson.build
parentc7973204247c777086a94f9f99af83c1a51b2d8e (diff)
downloadlibepoxy-950b9f5b25843d95c4667ef60038e8d7b476fbb8.tar.gz
meson: Set same variables in declare_dependency() as in pkgconfig
GTK currently fails to detect if epoxy has been built with EGL on Windows when epoxy is a subproject. To fix that it needs to get that information from the dependency variables. This requires Meson >=0.54.0 for setting variables in declare_dependency().
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index f42791c..ca37e80 100644
--- a/meson.build
+++ b/meson.build
@@ -5,7 +5,7 @@ project('libepoxy', 'c', version: '1.5.6',
'warning_level=1',
],
license: 'MIT',
- meson_version: '>= 0.48.0')
+ meson_version: '>= 0.54.0')
epoxy_version = meson.project_version().split('.')
epoxy_major_version = epoxy_version[0].to_int()