summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2018-02-23 15:51:56 +0000
committerEmmanuele Bassi <ebassi@gnome.org>2018-02-23 19:58:36 +0000
commita7c3178f86afa016ddeed8ebbb668ec308b71122 (patch)
treee3ef8ccef1ed6a9d37285fe18100d499058c8e11 /meson.build
parentc794dce0a088235344851e81511c6c5a532ec36c (diff)
downloadlibepoxy-a7c3178f86afa016ddeed8ebbb668ec308b71122.tar.gz
meson: Rename the configuration options
The `enable-` prefix is an Autotool-ism; idiomatic naming for Meson projects should just use the name of the option, and rely on the type to convey meaning, especially because Meson does not have `disable` aliases that avoid the explicit `enable-foo=no` cases.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 2def595..9281ea5 100644
--- a/meson.build
+++ b/meson.build
@@ -34,7 +34,7 @@ conf.set('HAVE_KHRPLATFORM_H', cc.has_header('KHR/khrplatform.h', required: fals
# configure time switch to enable or disable it; in case
# the "auto" default value is set, we only enable GLX
# support on Linux and Unix
-enable_glx = get_option('enable-glx')
+enable_glx = get_option('glx')
if enable_glx == 'auto'
if host_system == 'windows'
build_glx = false
@@ -53,7 +53,7 @@ elif enable_glx == 'no'
build_glx = false
endif
-enable_egl = get_option('enable-egl')
+enable_egl = get_option('egl')
if enable_egl == 'auto'
if host_system == 'windows'
build_egl = false
@@ -249,7 +249,7 @@ subdir('include/epoxy')
subdir('src')
subdir('test')
-if get_option('enable-docs')
+if get_option('docs')
doxygen = find_program('doxygen', required: false)
if doxygen.found()
subdir('doc')