summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2018-02-07 13:12:54 +0000
committerEmmanuele Bassi <ebassi@gnome.org>2018-02-23 10:57:53 +0000
commitb1119d8fcfe646f3ff108a3bf3685dfce6f049e4 (patch)
tree7a3ec8fb5f9340635134caf09c94e40d03e2f031 /meson.build
parent0d6aaa20eafb4752dde873533a68c8ca05dec3fe (diff)
downloadlibepoxy-b1119d8fcfe646f3ff108a3bf3685dfce6f049e4.tar.gz
meson: Generate the pkg-config file
Instead of using a template file, and filling in the blanks, we can use the Meson pkgconfig module to generate the pkg-config file mostly from the library object itself — including dependencies and flags. The template file remains in tree for the Autotools build.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 0 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index eb7e5cd..0f6dc71 100644
--- a/meson.build
+++ b/meson.build
@@ -231,12 +231,6 @@ if dl_dep.found()
pkgconf.set('DLOPEN_LIBS', '-ldl')
endif
-configure_file(input: 'epoxy.pc.in',
- output: 'epoxy.pc',
- configuration: pkgconf,
- install: true,
- install_dir: join_paths(epoxy_libdir, 'pkgconfig'))
-
# Python
python = import('python3').find_python()
if not python.found()