summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2017-03-01 20:44:07 +0000
committerEmmanuele Bassi <ebassi@gnome.org>2017-03-01 20:44:07 +0000
commitbdc2668757aa21744954377067a6d1c2aea4203f (patch)
tree8e5ae7fffc5f8f63029d64f020947c400fe9b1cb /meson.build
parent3eaddbef62ae83561417e6216cc72eeba98162f2 (diff)
downloadlibepoxy-bdc2668757aa21744954377067a6d1c2aea4203f.tar.gz
Remove /W3 from the MSVC compiler flags
Meson already uses /W2, like it uses -Wall with GCC.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 0 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index d271d95..470aef6 100644
--- a/meson.build
+++ b/meson.build
@@ -77,7 +77,6 @@ if cc.get_id() == 'msvc'
# Compiler options taken from msvc_recommended_pragmas.h
# in GLib, based on _Win32_Programming_ by Rector and Newcomer
test_cflags = [
- '-W3',
'-we4002', # too many actual parameters for macro
'-we4003', # not enough actual parameters for macro
'-w14010', # single-line comment contains line-continuation character