summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAndrei Fadeev <andrei@webcontrol.ru>2017-03-15 09:13:34 +0300
committerAndrei Fadeev <andrei@webcontrol.ru>2017-03-15 09:13:34 +0300
commitc39f16102ed1b22ad796e2416bb60792b9aa5571 (patch)
treeab88dafcfab795301b2f163f11f5d566ed77630b /meson.build
parentf7d3671a0fcad0f5371ce60916394e0269c5cee3 (diff)
downloadlibepoxy-c39f16102ed1b22ad796e2416bb60792b9aa5571.tar.gz
Fix build on MSVC
The inline keyword is available only for C++ in MSVC. So we need to use Microsoft specific __inline.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index a513f5f..7d9afd9 100644
--- a/meson.build
+++ b/meson.build
@@ -159,6 +159,14 @@ if libtype == 'shared'
endif
endif
+# The inline keyword is available only for C++ in MSVC.
+# So we need to use Microsoft specific __inline.
+if host_system == 'windows'
+ if cc.get_id() == 'msvc'
+ conf.set('inline', '__inline')
+ endif
+endif
+
# Dependencies
dl_dep = cc.find_library('dl', required: false)
gl_dep = dependency('gl', required: false)