summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2018-02-23 15:44:50 +0000
committerEmmanuele Bassi <ebassi@gnome.org>2018-02-23 16:05:50 +0000
commitce8cbdbe064f5fd7f3e78b6349fa86604e6189d7 (patch)
tree8b497a038caebc24a74c64d0d8ebc596c9b081fe /meson.build
parentbaa75c4a92bff37cb742a8c3ad42ab93e4f2a3d6 (diff)
downloadlibepoxy-ce8cbdbe064f5fd7f3e78b6349fa86604e6189d7.tar.gz
Allow building Epoxy without X11
Epoxy can be compiled with GLX and X11 native resources on EGL. We can disable the former, but the latter is always built in when enabling EGL support. Some platforms do not support X11 at all, so we need a way to disable X11 when configuring Epoxy.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 026d359..2def595 100644
--- a/meson.build
+++ b/meson.build
@@ -70,6 +70,14 @@ elif enable_egl == 'no'
build_egl = false
endif
+enable_x11 = get_option('x11')
+if not enable_x11
+ if enable_glx == 'yes'
+ error('GLX support is explicitly enabled, but X11 was disabled')
+ endif
+ build_glx = false
+endif
+
# The remaining platform specific API for GL/GLES are enabled
# depending on the platform we're building for
if host_system == 'windows'
@@ -88,6 +96,7 @@ endif
conf.set10('ENABLE_GLX', build_glx)
conf.set10('ENABLE_EGL', build_egl)
+conf.set10('ENABLE_X11', enable_x11)
# Compiler flags, taken from the Xorg macros
if cc.get_id() == 'msvc'