summaryrefslogtreecommitdiff
path: root/meson_options.txt
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-05-08 23:12:49 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-05-17 23:41:59 +0200
commit0511fc56e7017209ad18d16551ccaad05de9486c (patch)
treea00b146b6b58204be0f6307b137a6e195e4a05fd /meson_options.txt
parent5ef9c5ea24e5a0761baa2abda46c031eb0f6fd0f (diff)
downloadlibepoxy-0511fc56e7017209ad18d16551ccaad05de9486c.tar.gz
Make EGL support optional
It is perfectly possible to build Mesa3D with just OpenGL support, and use with GLX in X.org, without having EGL/OpenGLES support. However, libepoxy currently unconditionally requires EGL support in its configure.ac, which causes a build failure when Mesa3D only provides full OpenGL support: checking for EGL... no configure: error: Package requirements (egl) were not met: Package egl was not found in the pkg-config search path. Perhaps you should add the directory containing `egl.pc' to the PKG_CONFIG_PATH environment variable Package 'egl', required by 'world', not found This commit fixes that by: - Adjusting the configure.ac to add a --{enable,disable}-egl option handled in the exact same way as --{enable,disable}-glx - Adjusting the meson build logic in the same way. - Adjusting src/dispatch_common.h to define PLATFORM_HAS_EGL correctly, which allows to not include any EGL related header file if EGL support is not enabled. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'meson_options.txt')
-rw-r--r--meson_options.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson_options.txt b/meson_options.txt
index 18932f5..244476a 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -6,3 +6,8 @@ option('enable-glx',
choices: [ 'auto', 'yes', 'no' ],
value: 'auto',
description: 'Enable GLX support')
+option('enable-egl',
+ type: 'combo',
+ choices: [ 'auto', 'yes', 'no' ],
+ value: 'auto',
+ description: 'Enable EGL support')