summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2018-02-24 14:07:18 +0000
committerEmmanuele Bassi <ebassi@gnome.org>2018-02-24 14:09:37 +0000
commit28ca626eda5c331d94ad96b9e67f0b98177a9dbf (patch)
tree6ad7bd37fb71e476e9c21ef20506188a70b732f7 /test/meson.build
parente1ffd32d83d87c2bd90812f20344f253139d5c1b (diff)
downloadlibepoxy-28ca626eda5c331d94ad96b9e67f0b98177a9dbf.tar.gz
tests: Add EGL test for Epoxy API1.5.0
We have a few public entry points that we ought to test properly. Using the EGL API is easier to set up a test case, so let's just do that.
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index a72d02f..c5788b4 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -39,6 +39,7 @@ if build_egl and build_x11_tests
egl_tests = [
[ 'egl_has_extension_nocontext', [], [ 'egl_has_extension_nocontext.c' ], true, ],
+ [ 'egl_epoxy_api', [], [ 'egl_epoxy_api.c' ], true ],
[ 'egl_gles1_without_glx', [ '-DGLES_VERSION=1', ], [ 'egl_without_glx.c' ], has_gles1, ],
[ 'egl_gles2_without_glx', [ '-DGLES_VERSION=2', ], [ 'egl_without_glx.c' ], has_gles2, ],
]