summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2018-05-29 23:35:14 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2018-06-04 12:30:11 +0100
commit7e4b490ce72a555ac1ec272766ed63cba6bde0af (patch)
tree77625c191f0d0f22711f3495ebcdb63e3ad77b13 /test/meson.build
parentdadf83df009f6f6a77af1c74c5211b1420abc98c (diff)
downloadlibepoxy-7e4b490ce72a555ac1ec272766ed63cba6bde0af.tar.gz
Add a CoreGraphics OpenGL test for macOS
A basic test, to check that we're actually capable of working on macOS without GLX enabled.
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build23
1 files changed, 23 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index ea2b354..85e73d6 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -152,3 +152,26 @@ if build_wgl
test(test_name, test_bin)
endforeach
endif
+
+# Apple
+if host_machine.system().contains('darwin')
+ opengl_dep = dependency('appleframeworks', modules: ['OpenGL', 'Carbon'], required: true)
+
+ cgl_tests = [
+ [ 'cgl_core', [ 'cgl_core.c' ] ],
+ ]
+
+ foreach t: cgl_tests
+ test_name = t[0]
+ test_sources = t[1]
+
+ test(test_name,
+ executable(
+ test_name, test_sources,
+ c_args: test_cflags,
+ include_directories: libepoxy_inc,
+ dependencies: [ libepoxy_dep, opengl_dep ],
+ ),
+ )
+ endforeach
+endif