summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 2 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 0d75409..ae0cc88 100644
--- a/meson.build
+++ b/meson.build
@@ -223,17 +223,13 @@ configure_file(input: 'epoxy.pc.in',
install_dir: join_paths(epoxy_libdir, 'pkgconfig'))
# Python
-# XXX: Depend on 0.37.1 for:
-# python = import('python3').find_python()
-python = find_program('python3', required: false)
+python = import('python3').find_python()
if not python.found()
python = find_program('python', required: true)
endif
# Generates the dispatch tables
-# XXX: Depend on 0.38.1 for:
-# gen_dispatch_py = files('src/gen_dispatch.py')
-gen_dispatch_py = join_paths(meson.source_root(), 'src/gen_dispatch.py')
+gen_dispatch_py = files('src/gen_dispatch.py')
gl_registry = files('registry/gl.xml')
egl_registry = files('registry/egl.xml')