summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTushar Gohad <tushar.gohad@intel.com>2014-07-22 18:25:30 -0700
committerTushar Gohad <tushar.gohad@intel.com>2014-07-22 18:25:30 -0700
commit5b393fab81a3326553827ab7b1cda0ca008468a0 (patch)
tree5a86a722f8964ca9f5c1da11d851f51b2c76fc1a /Makefile.am
parente96f00ee117b936bd54ed04494122eca575ca066 (diff)
downloadliberasurecode-5b393fab81a3326553827ab7b1cda0ca008468a0.tar.gz
algsig: Move jerasure backend dlopen up a level
.. also check for errors Signed-off-by: Tushar Gohad <tushar.gohad@intel.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index b742621..d071c47 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -28,7 +28,7 @@ include_HEADERS = \
include/xor_codes/xor_code.h
test: check
-# @./test/alg_sig_test
+ @./test/alg_sig_test
@./test/test_xor_hd_code
@./test/liberasurecode_test
@@ -37,9 +37,9 @@ VALGRIND_EXEC_COMMAND = $(LIBTOOL_COMMAND) valgrind --tool=memcheck \
--malloc-fill=A5 --free-fill=DE --fullpath-after=.
valgrind-test: check
+ @$(VALGRIND_EXEC_COMMAND) ./test/alg_sig_test
@$(VALGRIND_EXEC_COMMAND) ./test/liberasurecode_test
@$(VALGRIND_EXEC_COMMAND) ./test/test_xor_hd_code
-# @$(VALGRIND_EXEC_COMMAND) ./test/alg_sig_test
CLEANFILES = cscope.in.out cscope.out cscope.po.out