summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTushar Gohad <tushar.gohad@intel.com>2014-07-13 19:22:48 -0700
committerTushar Gohad <tushar.gohad@intel.com>2014-07-13 19:26:23 -0700
commit6533759ba5060149886ed0a88ba8c9373f7bcdd7 (patch)
tree67aa2aee468d56e8d70ef3b8390ea985dea2f717 /Makefile.am
parent06e221f6708d5515296801af2ae14d6ea33e837e (diff)
downloadliberasurecode-6533759ba5060149886ed0a88ba8c9373f7bcdd7.tar.gz
Frontend/backend API split, make EC handle int type
.. also introduce a map for backend method stub name to backend library function names Signed-off-by: Tushar Gohad <tushar.gohad@intel.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index bf9868a..09cd80c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,9 +5,9 @@ SUBDIRS = src test
EXTRA_DIST = autogen.sh
if DEBUG
-AM_CFLAGS = -g3 -O0 -D_GNU_SOURCE=1
+AM_CFLAGS = -g3 -O0 -D_GNU_SOURCE=1 -Werror
else
-AM_CFLAGS = -O2 -D_GNU_SOURCE=1
+AM_CFLAGS = -O2 -D_GNU_SOURCE=1 -Werror
endif
INCLUDE = -I$(abs_top_builddir)/include \
@@ -22,7 +22,7 @@ AM_CFLAGS += -fPIC $(AM_CPPFLAGS) -L/usr/local/lib
include_HEADERS = \
include/erasurecode/list.h \
include/erasurecode/erasurecode_stdinc.h \
- include/erasurecode/erasurecode_internal.h \
+ include/erasurecode/erasurecode_backend.h \
include/erasurecode/erasurecode.h \
include/erasurecode/erasurecode_version.h \
include/xor_codes/xor_hd_code_defs.h \