summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Lambert <eric_lambert@xyratex.com>2014-06-19 16:44:41 -0700
committerEric Lambert <eric_lambert@xyratex.com>2014-06-19 16:44:41 -0700
commit69cce4911ac0fa250e677342224ab942001fcd37 (patch)
tree316de056a6dabb9db660cbccabfda4a370f03f5c /Makefile.am
parent19293caa23b50abf363897e41ee6e1cc8e06b88e (diff)
downloadliberasurecode-69cce4911ac0fa250e677342224ab942001fcd37.tar.gz
Fixed typo in 'check' make target and moved valgrind target
definition out of Makefile.in and into Makefile.am
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index f6cfc08..4212e8f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,6 +7,7 @@ else
AM_CFLAGS = -O2
endif
AM_CFLAGS += $(SIMD_FLAGS) -fPIC $(AM_CPPFLAGS) -L/usr/local/lib
+VALGRIND_EXEC_COMMAND = $(LIBTOOL_COMMAND) valgrind --tool=memcheck --error-exitcode=1 --leak-check=yes --track-fds=yes --malloc-fill=A5 --free-fill=DE --fullpath-after=.
include_HEADERS = include/xor_hd_code_defs.h include/xor_code.h include/alg_sig.h
lib_LTLIBRARIES =liberasurecode.la
liberasurecode_la_SOURCES =\
@@ -21,13 +22,17 @@ noinst_HEADERS = tests/test_xor_hd_code.h
test_xor_hd_code_SOURCES = tests/test_xor_hd_code.c tests/test_xor_hd_code.h
test_xor_hd_code_CPPFLAGS = -I./tests
test_xor_hd_code_LDFLAGS = -static -lerasurecode -lgf_complete
-check_PROGRAMS = text_xor_hd_code
+check_PROGRAMS = test_xor_hd_code
alg_sig_test_SOURCES = tests/alg_sig_test.c
alg_sig_test_CPPFLAGS = -I./tests
alg_sig_test_LDFLAGS = -static -lerasurecode -lgf_complete -lJerasure
check_PROGRAMS += alg_sig_test
-test: alg_sig_test test_xor_hd_code
- ./alg_sig_test
- ./test_xor_hd_code
+test: check
+ @./alg_sig_test
+ @./test_xor_hd_code
+
+valgrind-test: check
+ @$(VALGRIND_EXEC_COMMAND) ./alg_sig_test
+ @$(VALGRIND_EXEC_COMMAND) ./test_xor_hd_code