summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Lambert <eric_lambert@xyratex.com>2014-08-08 13:29:01 -0700
committerEric Lambert <eric_lambert@xyratex.com>2014-08-08 13:29:01 -0700
commit9b92176b4e00e287c09f540f4e801941418115b3 (patch)
treeaa830d315398dc797adb97e1e7c8e6b1b68356ec /Makefile.am
parentf83caee42afe6c500a4588b41e91ed8047ccb994 (diff)
downloadliberasurecode-9b92176b4e00e287c09f540f4e801941418115b3.tar.gz
Added ability to generate coverage data with configure --enable-gcov.
Currently only works on Linux (build/tests will run on OS X but coverage data is not generated).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 714d06f..6e23397 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,7 +11,7 @@ INCLUDE = -I$(abs_top_builddir)/include \
AM_CPPFLAGS = $(CPPFLAGS) $(INCLUDE)
AM_CPPFLAGS += -Werror
-AM_CFLAGS = -fPIC $(AM_CPPFLAGS) -L/usr/local/lib
+AM_CFLAGS = -fPIC $(AM_CPPFLAGS) @GCOV_FLAGS@ -L/usr/local/lib
include_HEADERS = \
include/erasurecode/alg_sig.h \
@@ -49,3 +49,4 @@ cscope:
find src include -name "*.[ch]" > cscope.files
cscope -q -b
+MOSTLYCLEANFILES = *.gcda *.gcno *.gcov