summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTushar Gohad <tushar.gohad@intel.com>2014-07-17 20:57:54 -0700
committerTushar Gohad <tushar.gohad@intel.com>2014-07-17 20:57:54 -0700
commita21e6e1a794cac5e9b353b0b0f8009f6a3295e26 (patch)
tree77988f87400544663dc20cbcb69c89b33c2e38c3 /Makefile.am
parentf033e1c74201648e7b1de7b9a63a184e76bc14f4 (diff)
downloadliberasurecode-a21e6e1a794cac5e9b353b0b0f8009f6a3295e26.tar.gz
Fix --enable-debug target, make debug CFLAGS consistent (global)
Signed-off-by: Tushar Gohad <tushar.gohad@intel.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 1 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index ef806c1..d7de3ba 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,12 +4,6 @@ ACLOCAL_AMFLAGS = -I m4
SUBDIRS = src test
EXTRA_DIST = autogen.sh
-if DEBUG
-AM_CFLAGS = -g3 -O0 -D_GNU_SOURCE=1 -Werror
-else
-AM_CFLAGS = -O2 -D_GNU_SOURCE=1 -Werror
-endif
-
INCLUDE = -I$(abs_top_builddir)/include \
-I$(abs_top_builddir)/include/erasurecode \
-I$(abs_top_builddir)/include/xor_codes
@@ -17,7 +11,7 @@ INCLUDE = -I$(abs_top_builddir)/include \
AM_CPPFLAGS = $(CPPFLAGS) $(INCLUDE)
AM_CPPFLAGS += -Werror
-AM_CFLAGS += -fPIC $(AM_CPPFLAGS) -L/usr/local/lib
+AM_CFLAGS = -fPIC $(AM_CPPFLAGS) -L/usr/local/lib
include_HEADERS = \
include/erasurecode/alg_sig.h \