summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTushar Gohad <tushar.gohad@intel.com>2015-09-18 18:43:20 +0000
committerTushar Gohad <tushar.gohad@intel.com>2015-09-20 19:39:24 +0000
commitbca105ccd31777a1b2cb956f61aeb03cc79664aa (patch)
tree81e5e520b887fb6a466c76e358f7c0f5556eaccd /Makefile.am
parentdc11fba6858e8a3fc8b83f36f45c96317e4a8d01 (diff)
downloadliberasurecode-bca105ccd31777a1b2cb956f61aeb03cc79664aa.tar.gz
Create header symlinks in std locations for backward compat
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e5ae47a..b05fff6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -30,6 +30,15 @@ thisinclude_HEADERS = \
include/rs_vand/rs_galois.h \
include/rs_vand/liberasurecode_rs_vand.h
+install-exec-hook:
+ -(cd $(DESTDIR)$(includedir) && \
+ rm erasurecode.h erasurecode_version.h \
+ erasurecode_stdinc.h config_liberasurecode.h && \
+ $(LN_S) liberasurecode/erasurecode.h && \
+ $(LN_S) liberasurecode/erasurecode_version.h && \
+ $(LN_S) liberasurecode/erasurecode_stdinc.h && \
+ $(LN_S) liberasurecode/config_liberasurecode.h)
+
test: check
$(eval SONAMES := $(shell find $(abs_top_builddir) -name '*.so'))
$(eval SODIRS := $(dir $(SONAMES)))