summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKevin Greenan <kmgreen2@gmail.com>2014-07-16 08:39:36 -0700
committerKevin Greenan <kmgreen2@gmail.com>2014-07-16 08:43:47 -0700
commit0be44ad3ca61604a719edc1257ca9dfc258bdc0b (patch)
tree46e34a2ebe90cb923d708f1f356b27096ac8c020 /configure.ac
parentc41559c125c9f5445221e39bf57439411443f2e4 (diff)
downloadliberasurecode-0be44ad3ca61604a719edc1257ca9dfc258bdc0b.tar.gz
Remove required gf-complete dependency from liberasurecode.
NOTE: We need to ensure that any erasure code backend using algebraic signatures *must use* the same exact GF as those used in this library. This usually means same 'w' and primitive polynomial. I plan to make the same change to Jerasure, so it will be compatible.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 10 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index c60892f..5480f79 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,16 +33,22 @@ AC_CHECK_FUNCS(malloc calloc realloc free)
# Check for jerasure/gf_complete headers
AC_CHECK_HEADERS(jerasure.h cauchy.h galois.h liberation.h reed_sol.h gf_complete.h)
-
+
# Enable this check when gf_complete is external
-AC_CHECK_LIB([gf_complete], [gf_init_easy], [],
+AC_CHECK_LIB([gf_complete], [gf_init_easy],
+[
+ AM_CONDITIONAL([GF_COMPLETE_INSTALLED], [true])
+ AC_DEFINE([HAVE_LIBGF_COMPLETE], [1], ["Defined if gf-complete is installed"])
+],
[
- echo "Error! gf_complete is required for algorithmic signature support."
+ echo "Warning gf_complete is required for *high performance* algorithmic signature support."
echo "gf_complete is available from https://bitbucket.org/jimplank/gf-complete.git"
echo "On Debian/Ubuntu systems, you can use \'apt-get install gf-complete\'"
- exit -1
+ echo "This will install with a slower Galois field backend!"
+ AM_CONDITIONAL([GF_COMPLETE_INSTALLED], [false])
])
+
AC_ARG_ENABLE(debug,
AS_HELP_STRING([--enable-debug],
[enable debugging, default: no]),