summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Lambert <eric_lambert@xyratex.com>2014-06-10 11:21:51 -0700
committerEric Lambert <eric_lambert@xyratex.com>2014-06-10 11:21:51 -0700
commit1ebd010a48094d8a19249d7a2e7f8988ca4d777d (patch)
tree969fe61690252c92893e5dcddffe38120eea9490 /configure.ac
parent71ef9117231988982d2d5e3fcbd31a9af4b7dd86 (diff)
downloadliberasurecode-1ebd010a48094d8a19249d7a2e7f8988ca4d777d.tar.gz
initial autoconf/automake work
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 14 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 19204a1..2da973e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,7 +1,7 @@
# c_eclib autoconf template
# FIXME - add project url as the last argument
-AC_INIT(c_eclib,0.9)
+AC_INIT(erasurecode,0.1)
AC_PREREQ([2.61])
@@ -23,19 +23,19 @@ AC_PROG_CC
# Check for jerasure/gf_complete headers
AC_CHECK_HEADERS(jerasure.h cauchy.h galois.h liberation.h reed_sol.h gf_complete.h)
-#AC_CHECK_LIB([Jerasure], [jerasure_autoconf_test], [],
-# [
-# echo "Error! You need to have libJerasure installed."
-# echo "libJerasure is available from bitbucket.org/kmgreen2/jerasure-kmg.git"
-# exit -1
-# ])
-#
-#AC_CHECK_LIB([gf_complete], [gf_init_easy], [],
-# [
-# echo "Error! You need to have gf_complete installed."
-# echo "gf_complete is available from http://web.eecs.utk.edu/~plank/plank/papers/CS-13-703.html"
-# exit -1
-# ])
+AC_CHECK_LIB([Jerasure], [jerasure_autoconf_test], [],
+ [
+ echo "Error! You need to have libJerasure installed."
+ echo "libJerasure is available from bitbucket.org/kmgreen2/jerasure-kmg.git"
+ exit -1
+ ])
+
+AC_CHECK_LIB([gf_complete], [gf_init_easy], [],
+ [
+ echo "Error! You need to have gf_complete installed."
+ echo "gf_complete is available from http://web.eecs.utk.edu/~plank/plank/papers/CS-13-703.html"
+ exit -1
+ ])
AX_EXT()