summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Lambert <eric_lambert@xyratex.com>2014-09-10 17:13:45 -0700
committerEric Lambert <eric_lambert@xyratex.com>2014-09-10 17:13:45 -0700
commit512353f8be456f9f8045faafbdb3356a4dbdb8ad (patch)
tree7081b07e838b6def308551c237411c1101fd0925 /configure.ac
parentcafa07b224255874a80b776fa5574971fbaabca3 (diff)
downloadliberasurecode-512353f8be456f9f8045faafbdb3356a4dbdb8ad.tar.gz
Compile in pedantic mode and fail compilation on warnings. Also cleanup all existing warnings.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 80e1ab4..4b5e6e9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -42,11 +42,11 @@ esac],[debug=false])
if test x$debug = xtrue ; then
DEBUG=1
CXXFLAGS=""
- CFLAGS="-O0 -ggdb -g3 -Werror -D_GNU_SOURCE=1"
+ CFLAGS="-O0 -ggdb -g3 -Werror -D_GNU_SOURCE=1 -Wall -pedantic -std=c99"
else
DEBUG=0
CXXFLAGS=""
- CFLAGS="-O2 -g -Werror -D_GNU_SOURCE=1"
+ CFLAGS="-O2 -g -Werror -D_GNU_SOURCE=1 -Wall -pedantic -std=c99"
fi
AC_ARG_ENABLE([gcov],