summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKevin Greenan <kmg@box.com>2014-07-22 13:32:23 -0700
committerKevin Greenan <kmg@box.com>2014-07-22 13:37:39 -0700
commit59bec942cb5e9a5c6206c5d2d46e443bf1ec09df (patch)
tree570d2d297a43f0715366725e912c382440089e57 /configure.ac
parentbde7428542598b838c5225b428b1e7c55b8ece29 (diff)
downloadliberasurecode-59bec942cb5e9a5c6206c5d2d46e443bf1ec09df.tar.gz
Ripping out galois.[ch] and dynamically pulling the multiplication functon from jerasure
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 0 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index 21c7df7..28e7246 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,23 +32,6 @@ AC_CHECK_HEADERS(sys/types.h stdio.h stdlib.h stddef.h stdarg.h malloc.h memory.
signal.h dlfcn.h pthread.h unistd.h limits.h errno.h syslog.h)
AC_CHECK_FUNCS(malloc calloc realloc free openlog)
-# Check for gf_complete headers
-AC_CHECK_HEADERS(galois.h gf_complete.h)
-
-# Enable this check when gf_complete is external
-AC_CHECK_LIB([gf_complete], [gf_init_easy],
-[
- AM_CONDITIONAL([GF_COMPLETE_INSTALLED], [true])
- AC_DEFINE([HAVE_LIBGF_COMPLETE], [1], ["Defined if gf-complete is installed"])
-],
-[
- echo "Warning gf_complete is required for *high performance* algorithmic signature support."
- echo "gf_complete is available from https://bitbucket.org/jimplank/gf-complete.git"
- echo "On Debian/Ubuntu systems, you can use \'apt-get install gf-complete\'"
- echo "This will install with a slower Galois field backend!"
- AM_CONDITIONAL([GF_COMPLETE_INSTALLED], [false])
-])
-
AC_ARG_ENABLE([debug],
[ --enable-debug Turn on debugging],
[case "${enableval}" in