summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTushar Gohad <tushar.gohad@intel.com>2014-07-06 08:23:24 -0700
committerTushar Gohad <tushar.gohad@intel.com>2014-07-06 09:59:06 -0700
commitb12209dc44af1c3c8fe05df765a7e97d27576230 (patch)
treec16f24662e41f0edc9ed449416ceb29f5523f012 /configure.ac
parentd72b7f9e66c579441b8e6f6fc28cc10524b7e9ce (diff)
downloadliberasurecode-b12209dc44af1c3c8fe05df765a7e97d27576230.tar.gz
autoconf: Make gf-complete dependency for algsig clearer
Signed-off-by: Tushar Gohad <tushar.gohad@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index ae1ee00..72289da 100644
--- a/configure.ac
+++ b/configure.ac
@@ -23,16 +23,17 @@ AC_PROG_MAKE_SET
dnl Check for C library headers
AC_HEADER_STDC
-AC_CHECK_HEADERS(sys/types.h stdio.h stdlib.h stddef.h stdarg.h \
- malloc.h memory.h string.h strings.h inttypes.h \
- stdint.h ctype.h math.h iconv.h signal.h dlfcn.h)
+AC_CHECK_HEADERS(sys/types.h stdio.h stdlib.h stddef.h stdarg.h malloc.h memory.h \
+ string.h strings.h inttypes.h stdint.h ctype.h math.h iconv.h \
+ signal.h dlfcn.h pthread.h)
AC_CHECK_FUNCS(malloc calloc realloc free)
# Enable this check when gf_complete is external
AC_CHECK_LIB([gf_complete], [gf_init_easy], [],
[
- echo "Error! You need to have gf_complete installed."
+ echo "Error! gf_complete is required for algorithmic signature support."
echo "gf_complete is available from https://bitbucket.org/jimplank/gf-complete.git"
+ echo "On Debian/Ubuntu systems, you can use \'apt-get install gf-complete\'"
exit -1
])