summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTushar Gohad <tushar.gohad@intel.com>2014-07-07 00:34:43 -0700
committerTushar Gohad <tushar.gohad@intel.com>2014-07-07 15:19:25 -0700
commitb5f2d046018eaee20c6b83b614d24aa6b81db0d7 (patch)
tree921e453f4f564df2f3bfe94fe7ca8d6d47bcb12b /configure.ac
parent5c5487296cc0f98c375b1bdc1deab02bc70dc480 (diff)
downloadliberasurecode-b5f2d046018eaee20c6b83b614d24aa6b81db0d7.tar.gz
autoconf: Move AX_EXT() up in order
.. so we don't add unnecessary libs to the AX_EXT compile lines .. this has a tendancy to report false failures if libraries .. are not found in LD_LIBRARY_PATH (e.g. -lgf_complete) Signed-off-by: Tushar Gohad <tushar.gohad@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 2114860..b5fbe76 100644
--- a/configure.ac
+++ b/configure.ac
@@ -22,6 +22,8 @@ AC_PROG_CXX
AC_PROG_INSTALL
AC_PROG_MAKE_SET
+AX_EXT()
+
dnl Check for C library headers
AC_HEADER_STDC
AC_CHECK_HEADERS(sys/types.h stdio.h stdlib.h stddef.h stdarg.h malloc.h memory.h \
@@ -29,6 +31,9 @@ AC_CHECK_HEADERS(sys/types.h stdio.h stdlib.h stddef.h stdarg.h malloc.h memory.
signal.h dlfcn.h pthread.h)
AC_CHECK_FUNCS(malloc calloc realloc free)
+# Check for jerasure/gf_complete headers
+AC_CHECK_HEADERS(jerasure.h cauchy.h galois.h liberation.h reed_sol.h gf_complete.h)
+
# Enable this check when gf_complete is external
AC_CHECK_LIB([gf_complete], [gf_init_easy], [],
[
@@ -38,11 +43,6 @@ AC_CHECK_LIB([gf_complete], [gf_init_easy], [],
exit -1
])
-# Check for jerasure/gf_complete headers
-AC_CHECK_HEADERS(jerasure.h cauchy.h galois.h liberation.h reed_sol.h gf_complete.h)
-
-AX_EXT()
-
AC_ARG_ENABLE(debug,
AS_HELP_STRING([--enable-debug],
[enable debugging, default: no]),