summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTushar Gohad <tushar.gohad@intel.com>2014-06-30 09:02:24 -0700
committerTushar Gohad <tushar.gohad@intel.com>2014-06-30 09:02:24 -0700
commitde3dbc5421fc8f21f8a91269a7efb1bb8707302f (patch)
treee304b412e2fa9b3bc773f26f14ce6f3183e3e27e /configure.ac
parent4f55dd887ca32ee3fa84c2084cc8c2652ae2d6c9 (diff)
downloadliberasurecode-de3dbc5421fc8f21f8a91269a7efb1bb8707302f.tar.gz
chksum: Add gf_complete dep for algsig
Signed-off-by: Tushar Gohad <tushar.gohad@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 14 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 65f22f0..4a9695e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,7 +9,6 @@ AC_PREREQ([2.61])
AM_INIT_AUTOMAKE([subdir-objects no-dependencies])
LT_INIT # libtool
-AC_CONFIG_SRCDIR(src)
AC_CONFIG_HEADER(include/config.h)
# Making releases:
@@ -79,6 +78,15 @@ AC_CHECK_HEADERS(sys/types.h stdio.h stdlib.h stddef.h stdarg.h \
stdint.h ctype.h math.h iconv.h signal.h dlfcn.h)
AC_CHECK_FUNCS(malloc calloc realloc free)
+# Enable this check when gf_complete is external
+AC_CHECK_LIB([gf_complete], [gf_init_easy], [],
+[
+ echo "Error! You need to have gf_complete installed."
+ echo "gf_complete is available from https://bitbucket.org/jimplank/gf-complete.git"
+ exit -1
+])
+
+
# C sources
SOURCES="$SOURCES $srcdir/src/*.c"
SOURCES="$SOURCES $srcdir/src/backends/null/*.c"
@@ -116,7 +124,9 @@ AC_SUBST(EXTRA_CFLAGS)
AC_SUBST(BUILD_LDFLAGS)
AC_SUBST(EXTRA_LDFLAGS)
-AC_OUTPUT(Makefile)
-AC_OUTPUT(erasurecode.pc)
-AC_OUTPUT(Xorcode.pc)
+AC_CONFIG_FILES([Makefile \
+ src/utils/chksum/Makefile \
+ erasurecode.pc \
+ Xorcode.pc])
+AC_OUTPUT