summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTushar Gohad <tushar.gohad@intel.com>2014-07-06 20:59:57 -0700
committerTushar Gohad <tushar.gohad@intel.com>2014-07-07 15:19:16 -0700
commitea7af2e7fcef4cc5fd5778e1672dca7b069d95db (patch)
tree9e8bccade3378bb974f5863a55dec5e2e826a407 /configure.ac
parent45eb51acfdc18ef85ed535d08139215be5552dda (diff)
downloadliberasurecode-ea7af2e7fcef4cc5fd5778e1672dca7b069d95db.tar.gz
xor code backend implementation (WIP)
Facing some nasty dlopen() issues when testing with "test/liberasurecode_test" Signed-off-by: Tushar Gohad <tushar.gohad@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 11 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 72289da..2114860 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,7 +3,7 @@ AC_GNU_SOURCE
AC_PREREQ([2.61])
-AM_INIT_AUTOMAKE([subdir-objects no-dependencies])
+AM_INIT_AUTOMAKE([subdir-objects no-dependencies silent-rules])
LT_INIT # libtool
AC_CONFIG_HEADER(include/config.h)
@@ -12,6 +12,7 @@ dnl Needed when reconfiguring with 'autoreconf -i -s'
AC_CONFIG_MACRO_DIR([m4])
AM_MAINTAINER_MODE([disable])
+AM_SILENT_RULES([yes])
dnl Compiling with per-target flags requires AM_PROG_CC_C_O.
AC_PROG_CC
@@ -57,10 +58,14 @@ dnl Expand the sources and objects needed to build the library
AC_SUBST(ac_aux_dir)
AC_SUBST(OBJECTS)
-AC_CONFIG_FILES([Makefile \
- src/builtin/xor_codes/Makefile \
- test/Makefile \
- erasurecode.pc \
- Xorcode.pc])
+AC_CONFIG_FILES([\
+ src/builtin/xor_codes/Makefile \
+ src/Makefile \
+ test/Makefile \
+ Makefile \
+ erasurecode.pc \
+ Xorcode.pc
+])
+
AC_OUTPUT