summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am15
1 files changed, 9 insertions, 6 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index eb2f89f..b043de8 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -2,12 +2,15 @@ SUBDIRS = builtin/xor_codes builtin/null_code builtin/rs_vand
lib_LTLIBRARIES = liberasurecode.la
-INCLUDES = \
- -I$(top_srcdir)/include/erasurecode \
- -I$(top_srcdir)/include/xor_codes \
- -I$(top_srcdir)/include/rs_vand \
- -I$(top_srcdir)/include/isa_l \
- -I$(top_srcdir)/include/shss
+INCLUDE = \
+ -I$(abs_top_srcdir)/include/erasurecode \
+ -I$(abs_top_srcdir)/include/xor_codes \
+ -I$(abs_top_srcdir)/include/rs_vand \
+ -I$(abs_top_srcdir)/include/isa_l \
+ -I$(abs_top_srcdir)/include/shss
+
+AM_CPPFLAGS = $(CPPFLAGS) $(INCLUDE)
+AM_CFLAGS = $(AM_CPPFLAGS)
# liberasurecode params
liberasurecode_la_SOURCES = \