summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAzat Khuzhin <azat@libevent.org>2020-09-01 01:08:16 +0300
committerAzat Khuzhin <azat@libevent.org>2020-09-01 01:08:50 +0300
commit02428d9a2d89ee0a595166909dd6d75b5beb777b (patch)
treeec02504d603c66428b4b58bc66af096cf990e756 /CMakeLists.txt
parentc2a9ecffefc5c547cadddbff90e2a574be58168e (diff)
downloadlibevent-02428d9a2d89ee0a595166909dd6d75b5beb777b.tar.gz
build: fix building under windows with thread support
Fixes: 972289f3 ("Detect existence of pthread_mutexattr_setprotocol()")
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 014044cb..93f66830 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -831,7 +831,7 @@ set(HDR_PUBLIC
include/event2/visibility.h
${PROJECT_BINARY_DIR}/include/event2/event-config.h)
-set(SRC_CORE
+list(APPEND SRC_CORE
buffer.c
bufferevent.c
bufferevent_filter.c