summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPaweł Wegner <lemourin@google.com>2021-05-13 17:32:11 +0200
committerPaweł Wegner <pawel.wegner95@gmail.com>2021-05-14 14:07:30 +0200
commit087bbc572c48d9304d8b6b911e6b0cf966ba3c28 (patch)
treef483f57bd71fbda2ada23f8bdeb30b97363ee560 /CMakeLists.txt
parent1fe8b3d6a4972e5a8891804a8751d408184097e8 (diff)
downloadlibevent-087bbc572c48d9304d8b6b911e6b0cf966ba3c28.tar.gz
cmake: don't override CMAKE_CONFIGURATION_TYPES.
Surprisingly this overrides configuration types for projects which embed libevent using cmake's add_subdirectory.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ac59e97b..6acf2414 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -37,10 +37,6 @@ if(NOT CMAKE_BUILD_TYPE)
endif()
string(TOLOWER "${CMAKE_BUILD_TYPE}" CMAKE_BUILD_TYPE_LOWER)
-# get rid of the extra default configurations
-# what? why would you get id of other useful build types? - Ellzey
-set(CMAKE_CONFIGURATION_TYPES "Debug;Release" CACHE STRING "Limited configurations" FORCE)
-
set(EVENT__LIBRARY_TYPE DEFAULT CACHE STRING
"Set library type to SHARED/STATIC/BOTH (default SHARED for MSVC, otherwise BOTH)")