summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDmitry Antipov <dantipov@cloudlinux.com>2023-01-02 17:06:48 +0300
committerDmitry Antipov <dantipov@cloudlinux.com>2023-01-02 17:12:14 +0300
commit0b79a0024fcc53a322bf63f6e2301173de7dc9de (patch)
tree2020ecb25a6b584fdea23cc0f1496e6944fbecd0 /CMakeLists.txt
parent1fe626c4da14fef6cf45b95e48a438e0f93a499e (diff)
downloadlibevent-0b79a0024fcc53a322bf63f6e2301173de7dc9de.tar.gz
buffer: use pread() for evbuffer_file_segment_materialize()
If pread(2) is available, prefer it over double lseek(2) and read(2) in evbuffer_file_segment_materialize(). Signed-off-by: Dmitry Antipov <dantipov@cloudlinux.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a4b54d46..5cf1ea45 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -530,6 +530,7 @@ else()
mmap
pipe
pipe2
+ pread
sendfile
sigaction
strsignal