summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDmitry Antipov <dantipov@cloudlinux.com>2022-09-15 14:06:50 +0300
committerAzat Khuzhin <a3at.mail@gmail.com>2022-09-27 22:07:43 +0300
commit117ee9a03fc74617e378f755c6b25005ac0e954f (patch)
treebfc4b1740bffab2dd13f4a2cccd59fe12fef8ff0 /CMakeLists.txt
parentf8bb9d84845be12b3ffb709bf9a26df4f40f898f (diff)
downloadlibevent-117ee9a03fc74617e378f755c6b25005ac0e954f.tar.gz
epoll: use epoll_pwait2() if available
On GNU/Linux with epoll backend, prefer epoll_pwait2() if available, which is useful to support the timeout with microsecond precision.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c66fe9e6..20bdc92e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -518,6 +518,7 @@ else()
select
epoll_create
epoll_create1
+ epoll_pwait2
epoll_ctl
eventfd
poll