summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoryuangongji <82787816@qq.com>2019-10-25 21:54:13 +0800
committeryuangongji <82787816@qq.com>2019-10-25 21:54:13 +0800
commit5fe83d7433022e29a401753f64ec78faaf25e0a7 (patch)
treed68f6a251489f55629715c719f20bfca38516511 /CMakeLists.txt
parent1ba94bdf0861b989307d8ebec207ba01b97970e7 (diff)
downloadlibevent-5fe83d7433022e29a401753f64ec78faaf25e0a7.tar.gz
cmake: eliminate duplicate installation of public headers
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9c438033..897ddf6f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1489,6 +1489,11 @@ install(FILES ${HDR_COMPAT}
DESTINATION "include"
COMPONENT dev)
+# Install public headers
+install(FILES ${HDR_PUBLIC}
+ DESTINATION "include/event2"
+ COMPONENT dev)
+
# Install the configs.
install(FILES
${PROJECT_BINARY_DIR}/${CMAKE_FILES_DIRECTORY}/LibeventConfig.cmake