summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2021-03-28 10:35:22 +0800
committerfanquake <fanquake@gmail.com>2021-03-28 13:55:59 +0800
commit78e8541a9e2d3bfd89cd878864bffb8d25c38141 (patch)
tree4dcd79b2f439ffd1d12ceeccdca3db0737fe4908 /CMakeLists.txt
parent4c29b01c87af4739a0e846f5879fa0f5db287f10 (diff)
downloadlibevent-78e8541a9e2d3bfd89cd878864bffb8d25c38141.tar.gz
build: remove no-longer used checks for vasprintf
From what I can tell the last usage was removed in 8d1317d71c46e27c5073d3429a64af69de0351a6.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8fa79683..ac59e97b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -473,7 +473,6 @@ list(APPEND SYMBOLS_TO_CHECK
strlcpy
strsep
strtok_r
- vasprintf
timerclear
timercmp
timerisset
@@ -551,7 +550,6 @@ if (NOT EVENT__DISABLE_THREAD_SUPPORT)
endif()
endif()
-# Add stdio.h for vasprintf
list(APPEND CMAKE_EXTRA_INCLUDE_FILES ${EVENT_INCLUDES} stdio.h)
CHECK_SYMBOLS_EXIST("${SYMBOLS_TO_CHECK}" "${CMAKE_EXTRA_INCLUDE_FILES}" "EVENT")
unset(SYMBOLS_TO_CHECK)