summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAzat Khuzhin <a3at.mail@gmail.com>2016-01-12 01:57:07 +0300
committerAzat Khuzhin <a3at.mail@gmail.com>2016-01-14 11:58:39 +0300
commita1609a87d7553f256c1651a4835e3f4a3a3dba44 (patch)
treeee38d0bf64c1645461e9c0ef1e5d4e26b1164478 /CMakeLists.txt
parentbb6b53d031f19b80a590b94513328cdd55f63968 (diff)
downloadlibevent-a1609a87d7553f256c1651a4835e3f4a3a3dba44.tar.gz
cmake: fix building dns-example under win32 (missing getopt)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4acb9961..708f8a1b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -889,6 +889,12 @@ if (NOT EVENT__DISABLE_SAMPLES)
add_dependencies(${SAMPLE} event_extra)
endforeach()
+
+ if (WIN32)
+ target_sources(dns-example PUBLIC
+ WIN32-Code/getopt.c
+ WIN32-Code/getopt_long.c)
+ endif()
endif()
if (NOT EVENT__DISABLE_BENCHMARK)