summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorokhowang(王沛文) <okhowang@tencent.com>2020-09-16 11:31:33 +0800
committerokhowang(王沛文) <okhowang@tencent.com>2020-09-16 11:57:52 +0800
commitb45a02efab20581e4ddbd3108b110f21a636aa4d (patch)
treec9de7f840acd37f6a3f12a3d637b640fc1d793cb /CMakeLists.txt
parent53c6867520ccf4712f569ee2686a1a5b04fd7c8d (diff)
downloadlibevent-b45a02efab20581e4ddbd3108b110f21a636aa4d.tar.gz
sample: add https-client-mbedtls
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 93f66830..0b188861 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1085,6 +1085,9 @@ if (NOT EVENT__DISABLE_SAMPLES)
endif()
if (NOT EVENT__DISABLE_MBEDTLS)
+ add_sample_prog(event_mbedtls https-client-mbedtls
+ sample/https-client.c)
+ target_compile_definitions(https-client-mbedtls PRIVATE USE_MBEDTLS)
add_sample_prog(event_mbedtls ssl-client-mbedtls
sample/ssl-client-mbedtls.c)
endif()