summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAzat Khuzhin <azat@libevent.org>2022-07-09 14:22:38 +0300
committerAzat Khuzhin <azat@libevent.org>2022-07-09 17:16:56 +0300
commitf5ad737d73ed18b95ce63f1d8e933a89a26653e9 (patch)
tree315238f645066c1aa7d6331f4efdf1708551cac9 /CMakeLists.txt
parent1bc62ce1718c720fd64e6e2db408bfb07d04b88e (diff)
downloadlibevent-f5ad737d73ed18b95ce63f1d8e933a89a26653e9.tar.gz
Add -Wundef for cmake and fix EVENT__SIZEOF_TIME_T usage
Note, autotools already supports it.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5ee0df2f..9237252c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -295,6 +295,7 @@ if (${GNUC})
list(APPEND __FLAGS
-Wall -Wextra -Wno-unused-parameter -Wstrict-aliasing -Wstrict-prototypes
+ -Wundef
-fno-strict-aliasing # gcc 2.9.5+
-Wmissing-prototypes