summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authoryuangongji <82787816@qq.com>2019-07-27 22:41:39 +0800
committerAzat Khuzhin <a3at.mail@gmail.com>2019-07-30 10:06:36 +0300
commit1947dd0ddbced0d8f9891656c820353f82261c52 (patch)
tree7b960ba8134c07ab2b2d800399aecd27b3cc5869 /Makefile.am
parent55d1e20e1a5dbd1188f4143968f7cafee33edc0d (diff)
downloadlibevent-1947dd0ddbced0d8f9891656c820353f82261c52.tar.gz
Change autoconf version to 2.62 and automake version to 1.11.2
On my computer, the version of autoconf is 2.59 and automake is 1.9 I build with autogen.sh & configure & make and failed. I find In Makefile.am: include/event2/event-config.h: config.h make-event-config.sed $(AM_V_GEN)test -d include/event2 || $(MKDIR_P) include/event2 $(AM_V_at)$(SED) -f $(srcdir)/make-event-config.sed < config.h > $@T $(AM_V_at)mv -f $@T $@ There are three undefined variables: MKDIR_P, AM_V_GEN and AM_V_at. Then I tried: - autoconf-2.60 / automake-1.10 - autoconf-2.61 / automake-1.11 - autoconf-2.62 / automake-1.11.2 And only autoconf-2.62 & automake-1.11.2 is ok. Therefore, I recommend changing the autoconf version from 2.59 to 2.62 and automake version from 1.9 to 1.11.2. Plus autoconf 2.59 is too old - 2003.12.16 [1], so as automake 1.9 - 2004.08.11 [2], while $(AM_V_GEN)/$(AM_V_at) had been introduced in 371a1237 back in 2012. [1]: http://ftp.gnu.org/gnu/autoconf/ [1]: http://ftp.gnu.org/gnu/automake/ Fixes: 371a1237 ("Make quiet build even quieter")
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index c8e3ec2a..af75a963 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,8 +5,8 @@
# See LICENSE for copying information.
# 'foreign' means that we're not enforcing GNU package rules strictly.
-# '1.9' means that we need automake 1.9 or later (and we do).
-AUTOMAKE_OPTIONS = foreign 1.9 subdir-objects
+# '1.11.2' means that we need automake 1.11.2 or later (and we do).
+AUTOMAKE_OPTIONS = foreign 1.11.2 subdir-objects
ACLOCAL_AMFLAGS = -I m4