summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2009-04-10 15:01:31 +0000
committerNick Mathewson <nickm@torproject.org>2009-04-10 15:01:31 +0000
commit23085c92477035507c499530d4a200bceee5d8a1 (patch)
treec24947a8b1af1cf0c7b1beacc158f6f1a276a3f4 /Makefile.am
parent8161662007e4ffe8c71e3f8267733b2131d8d619 (diff)
downloadlibevent-23085c92477035507c499530d4a200bceee5d8a1.tar.gz
Add a linked-pair abstraction to bufferevents.
The new bufferevent_pair abstraction works like a set of buferevent_sockets connected by a socketpair, except that it doesn't require a socketpair, and therefore doesn't need to get the kernel involved. It's also a good way to make sure that deferred callbacks work. It's a good use case for deferred callbacks: before I implemented them, the recursive relationship between the evbuffer callback and the read callback would make the unit tests overflow the stack. svn:r1152
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 13d13546..1c7cb87e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -90,6 +90,7 @@ event-config.h: config.h
CORE_SRC = event.c buffer.c \
bufferevent.c bufferevent_sock.c bufferevent_filter.c \
+ bufferevent_pair.c \
evmap.c log.c evutil.c strlcpy.c $(SYS_SRC)
EXTRA_SRC = event_tagging.c http.c evdns.c evrpc.c