summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2007-09-20 18:26:40 +0000
committerNick Mathewson <nickm@torproject.org>2007-09-20 18:26:40 +0000
commit250071830a701193c72aa8a65bd9afa5f74692fe (patch)
treeb3bce2543d799019ace5bd2bb99ebb18c273e536 /Makefile.am
parent626cc5f982f648e4d669178dc5e0bbb1f4ddb6d6 (diff)
downloadlibevent-250071830a701193c72aa8a65bd9afa5f74692fe.tar.gz
r15216@catbus: nickm | 2007-09-20 13:58:23 -0400
Add a new evutil module to contain the usual cross-platform hacks: socketpair, closesocket, and make_socket_nonblocking() svn:r441
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index f89c0bc0..ff806910 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -40,13 +40,14 @@ SYS_INCLUDES =
endif
libevent_la_SOURCES = event.c buffer.c evbuffer.c log.c event_tagging.c \
- http.c evhttp.h http-internal.h evdns.c evdns.h evrpc.c strlcpy.c \
+ http.c evhttp.h http-internal.h evdns.c evdns.h evrpc.c evutil.c \
+ strlcpy.c \
strlcpy-internal.h evrpc.h evrpc-internal.h strlcpy-internal.h \
$(SYS_SRC)
libevent_la_LIBADD = @LTLIBOBJS@ $(SYS_LIBS)
libevent_la_LDFLAGS = -release @VERSION@ -version-info 1:3:0
-include_HEADERS = event.h evhttp.h evdns.h evrpc.h
+include_HEADERS = event.h evhttp.h evdns.h evrpc.h evutil.h
INCLUDES = -I$(srcdir)/compat $(SYS_INCLUDES)