summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2009-01-21 07:51:25 +0000
committerNick Mathewson <nickm@torproject.org>2009-01-21 07:51:25 +0000
commit309fc7c4ad34f7e50245c305a776a5e04b4a0555 (patch)
tree07d5a87f1290b387d0ae15aa71f58b11adea05ac /Makefile.am
parent70405e3c7a184a11be506e2e4fd4774e867f978b (diff)
downloadlibevent-309fc7c4ad34f7e50245c305a776a5e04b4a0555.tar.gz
New functions to provide sane threading callbacks with pthreads and win32 threading implementations.
svn:r1031
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a05a223a..47d177e1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -39,6 +39,8 @@ EXTRA_DIST = \
test/test-eof.c test/test-weof.c test/test-time.c \
test/test-init.c test/test.sh \
compat/sys/queue.h compat/sys/_time.h \
+ evthread_win32.c \
+ evthread_pthread.c \
WIN32-Code/config.h \
WIN32-Code/win32.c \
WIN32-Code/tree.h \
@@ -48,13 +50,16 @@ EXTRA_DIST = \
WIN32-Prj/time_test/time_test.dsp
lib_LTLIBRARIES = libevent.la libevent_core.la libevent_extra.la
+if PTHREADS
+lib_LTLIBRARIES += libevent_pthreads.la
+endif
SUBDIRS = . include sample test
if BUILD_WIN32
SYS_LIBS = -lws2_32
-SYS_SRC = WIN32-Code/win32.c
+SYS_SRC = WIN32-Code/win32.c evthread_win32.c
SYS_INCLUDES = -IWIN32-Code
else
@@ -94,6 +99,10 @@ libevent_core_la_SOURCES = $(CORE_SRC)
libevent_core_la_LIBADD = @LTLIBOBJS@ $(SYS_LIBS)
libevent_core_la_LDFLAGS = -release $(RELEASE) -version-info $(VERSION_INFO)
+if PTHREADS
+libevent_pthreads_la_SOURCES = evthread_pthread.c
+endif
+
libevent_extra_la_SOURCES = $(EXTRA_SRC)
libevent_extra_la_LIBADD =
libevent_extra_la_LDFLAGS = -release $(RELEASE) -version-info $(VERSION_INFO)