summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2013-03-31 14:05:26 -0400
committerNick Mathewson <nickm@torproject.org>2013-03-31 14:05:26 -0400
commit4914620025a7e457fc4c3a936441fce681bb6c38 (patch)
tree286d5607dfee035f8d0c1d523927bd009b31e925 /Makefile.am
parent81ea0c4c7ae19f9b4e9142414e3db1d7b08e3b10 (diff)
downloadlibevent-4914620025a7e457fc4c3a936441fce681bb6c38.tar.gz
Do not build strlcpy.c when it will have no code.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index baf15247..24853c9e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -156,6 +156,9 @@ SYS_INCLUDES =
endif
+if STRLCPY_IMPL
+SYS_SRC += strlcpy.c
+endif
if SELECT_BACKEND
SYS_SRC += select.c
endif
@@ -200,7 +203,6 @@ CORE_SRC = \
evutil_time.c \
listener.c \
log.c \
- strlcpy.c \
$(SYS_SRC)
EXTRAS_SRC = \