summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2012-02-29 15:07:31 -0500
committerNick Mathewson <nickm@torproject.org>2012-02-29 15:07:31 -0500
commit639383a45427ecfb3dc305bbefc345abf7d31940 (patch)
tree7bd4e6bcfb5c3c7bc6dc2e804713792505317bdb /Makefile.am
parent5c0f7e06ce8c636b0d899ea19cd5b292c839e60c (diff)
downloadlibevent-639383a45427ecfb3dc305bbefc345abf7d31940.tar.gz
Make the generated event-config.h use correct include guards
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index a16c9cf2..ac138afe 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -173,8 +173,8 @@ BUILT_SOURCES = ./include/event2/event-config.h
echo ' *' >> $@
echo ' * Do not rely on macros in this file existing in later versions.'>> $@
echo ' */' >> $@
- echo '#ifndef _EVENT2_EVENT_CONFIG_H_' >> $@
- echo '#define _EVENT2_EVENT_CONFIG_H_' >> $@
+ echo '#ifndef EVENT2_EVENT_CONFIG_H_INCLUDED_' >> $@
+ echo '#define EVENT2_EVENT_CONFIG_H_INCLUDED_' >> $@
sed -e 's/#define /#define EVENT__/' \
-e 's/#undef /#undef EVENT__/' \