summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Grifka <nigri@microsoft.com>2020-04-22 19:44:45 -0700
committerAzat Khuzhin <azat@libevent.org>2020-05-08 23:27:04 +0300
commit83ef3216e4a9f1711f260af3889c94cbcbbefacb (patch)
treebb95689293ca520fe6b1aac597215c8e751c22a5 /Makefile.am
parent06a11929511bebaaf40c52aaf91de397b1782ba2 (diff)
downloadlibevent-83ef3216e4a9f1711f260af3889c94cbcbbefacb.tar.gz
Add wepoll support to light up the epoll backend on Windows
libevent is lacking a scalable backend on Windows. Let's leverage the wepoll library until Windows comes up with an epoll/kqueue compete user mode API. - All regress tests pass for standard wepoll - These 2 tests fail intermittently for changelist wepoll, so disabling changelist wepoll for now http/cancel_inactive_server http/stream_in - verify target on Windows runs tests for both wepoll and win32 backends - wepoll backend preferred over win32 backend - wepoll version 1.5.6 v2: cleaner backend abstraction. Disallow wepoll on MinGW/Cygwin. v3: Add wepoll.h to dist v4: Make sure wepoll source files are excluded from cygwin/mingw builds v5: Keep win32 as default backend on windows. v6: Include wepoll in mingw builds. Verified that regress tests pass w/ WEPOLL backend. v7: Enable wepoll on mingw when building with cmake v8: Add wepoll testrunner for autotools test target
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 7841e875..93765555 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -220,6 +220,10 @@ endif
if EVPORT_BACKEND
SYS_SRC += evport.c
endif
+if WEPOLL_BACKEND
+SYS_SRC += epoll.c
+SYS_SRC += wepoll.c
+endif
if SIGNAL_SUPPORT
SYS_SRC += signal.c
endif
@@ -323,7 +327,8 @@ noinst_HEADERS += \
strlcpy-internal.h \
time-internal.h \
util-internal.h \
- openssl-compat.h
+ openssl-compat.h \
+ wepoll.h
EVENT1_HDRS = \
include/evdns.h \