summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAzat Khuzhin <a3at.mail@gmail.com>2016-08-07 22:19:39 +0300
committerAzat Khuzhin <a3at.mail@gmail.com>2016-08-09 15:47:58 +0300
commitbb09535bdad6a6398eee3123d0dd7857fa60c825 (patch)
tree30bac45ee3656c3dae82a92ca25c972a2420ebcd /Makefile.am
parent18108574256f6a0e28a1d5b543774cd7089f7396 (diff)
downloadlibevent-bb09535bdad6a6398eee3123d0dd7857fa60c825.tar.gz
autoconf: fix --disable-thread-support build under win32
Fixes: https://ci.appveyor.com/project/azat/libevent/build/job/gvud4tcqsd5bnarl Fixes: https://ci.appveyor.com/project/azat/libevent/build/2.1.6.80/job/5frnb1c3n4quxxqy Fixes: https://ci.appveyor.com/project/azat/libevent/build/2.1.6.80/job/3wdahbrew7setmoa
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index f740bf3d..71fa834e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -142,10 +142,14 @@ include test/include.am
if BUILD_WIN32
SYS_LIBS = -lws2_32 -lshell32 -ladvapi32
-SYS_SRC = win32select.c evthread_win32.c buffer_iocp.c event_iocp.c \
+SYS_SRC = win32select.c buffer_iocp.c event_iocp.c \
bufferevent_async.c
SYS_INCLUDES = -IWIN32-Code -IWIN32-Code/nmake
+if THREADS
+SYS_SRC += evthread_win32.c
+endif
+
else
SYS_LIBS =