summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDmitry Antipov <dantipov@cloudlinux.com>2022-09-15 14:06:50 +0300
committerAzat Khuzhin <a3at.mail@gmail.com>2022-09-27 22:07:43 +0300
commit117ee9a03fc74617e378f755c6b25005ac0e954f (patch)
treebfc4b1740bffab2dd13f4a2cccd59fe12fef8ff0 /configure.ac
parentf8bb9d84845be12b3ffb709bf9a26df4f40f898f (diff)
downloadlibevent-117ee9a03fc74617e378f755c6b25005ac0e954f.tar.gz
epoll: use epoll_pwait2() if available
On GNU/Linux with epoll backend, prefer epoll_pwait2() if available, which is useful to support the timeout with microsecond precision.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b0a37fe8..cc961692 100644
--- a/configure.ac
+++ b/configure.ac
@@ -272,7 +272,7 @@ dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_INLINE
dnl Checks for library functions.
-AC_CHECK_FUNCS([accept4 arc4random arc4random_buf arc4random_addrandom eventfd epoll_create1 fcntl getegid geteuid getifaddrs gettimeofday issetugid mach_absolute_time mmap nanosleep pipe pipe2 putenv sendfile setenv setrlimit sigaction signal strsignal strlcpy strsep strtok_r strtoll sysctl timerfd_create umask unsetenv usleep getrandom mmap64])
+AC_CHECK_FUNCS([accept4 arc4random arc4random_buf arc4random_addrandom eventfd epoll_create1 epoll_pwait2 fcntl getegid geteuid getifaddrs gettimeofday issetugid mach_absolute_time mmap nanosleep pipe pipe2 putenv sendfile setenv setrlimit sigaction signal strsignal strlcpy strsep strtok_r strtoll sysctl timerfd_create umask unsetenv usleep getrandom mmap64])
AS_IF([test "$bwin32" = "true"],
AC_CHECK_FUNCS(_gmtime64_s, , [AC_CHECK_FUNCS(_gmtime64)])