summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2021-06-15 14:34:46 +0800
committerfanquake <fanquake@gmail.com>2021-07-09 12:34:10 +0800
commit5f11857fd7f38bc6c730bfd6a51417fb323451b7 (patch)
tree83c250189147d2f592ab867c719628a2d2fc106b /configure.ac
parent67f808ece8cff2f130efd90a9f77a2dbce918153 (diff)
downloadlibevent-5f11857fd7f38bc6c730bfd6a51417fb323451b7.tar.gz
build: quote args in AC_ARG_ENABLE & AS_HELP_STRING
Previously, some were, some weren't. Consolidate on quoting.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 19 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index 57702de9..e53451c6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,32 +36,32 @@ AC_PROG_INSTALL
AC_PROG_LN_S
AC_PROG_SED
-AC_ARG_ENABLE(gcc-warnings,
- AS_HELP_STRING(--disable-gcc-warnings, disable verbose warnings with GCC))
+AC_ARG_ENABLE([gcc-warnings],
+ AS_HELP_STRING([--disable-gcc-warnings, disable verbose warnings with GCC]))
-AC_ARG_ENABLE(gcc-hardening,
- AS_HELP_STRING(--enable-gcc-hardening, enable compiler security checks),
+AC_ARG_ENABLE([gcc-hardening],
+ AS_HELP_STRING([--enable-gcc-hardening, enable compiler security checks]),
[if test x$enableval = xyes; then
CFLAGS="$CFLAGS -D_FORTIFY_SOURCE=2 -fstack-protector-all"
CFLAGS="$CFLAGS -fwrapv -fPIE -Wstack-protector"
CFLAGS="$CFLAGS --param ssp-buffer-size=1"
fi])
-AC_ARG_ENABLE(thread-support,
- AS_HELP_STRING(--disable-thread-support, disable support for threading),
+AC_ARG_ENABLE([thread-support],
+ AS_HELP_STRING([--disable-thread-support, disable support for threading]),
[], [enable_thread_support=yes])
-AC_ARG_ENABLE(malloc-replacement,
- AS_HELP_STRING(--disable-malloc-replacement, disable support for replacing the memory mgt functions),
- [], [enable_malloc_replacement=yes])
-AC_ARG_ENABLE(openssl,
- AS_HELP_STRING(--disable-openssl, disable support for openssl encryption),
- [], [enable_openssl=yes])
-AC_ARG_ENABLE(mbedtls,
- AS_HELP_STRING(--disable-mbedtls, disable support for mbedtls encryption),
- [], [enable_mbedtls=yes])
-AC_ARG_ENABLE(debug-mode,
- AS_HELP_STRING(--disable-debug-mode, disable support for running in debug mode),
- [], [enable_debug_mode=yes])
+AC_ARG_ENABLE([malloc-replacement],
+ AS_HELP_STRING([--disable-malloc-replacement, disable support for replacing the memory mgt functions]),
+ [], [enable_malloc_replacement=yes])
+AC_ARG_ENABLE([openssl],
+ AS_HELP_STRING([--disable-openssl, disable support for openssl encryption]),
+ [], [enable_openssl=yes])
+AC_ARG_ENABLE([mbedtls],
+ AS_HELP_STRING([--disable-mbedtls, disable support for mbedtls encryption]),
+ [], [enable_mbedtls=yes])
+AC_ARG_ENABLE([debug-mode],
+ AS_HELP_STRING([--disable-debug-mode, disable support for running in debug mode]),
+ [], [enable_debug_mode=yes])
AC_ARG_ENABLE([libevent-install],
AS_HELP_STRING([--disable-libevent-install, disable installation of libevent]),
[], [enable_libevent_install=yes])
@@ -78,7 +78,7 @@ AC_ARG_ENABLE([verbose-debug],
AS_HELP_STRING([--enable-verbose-debug, verbose debug logging]),
[], [enable_verbose_debug=no])
AC_ARG_ENABLE([clock-gettime],
- AS_HELP_STRING(--disable-clock-gettime, do not use clock_gettime even if it is available),
+ AS_HELP_STRING([--disable-clock-gettime, do not use clock_gettime even if it is available]),
[], [enable_clock_gettime=yes])