summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2013-04-25 13:43:49 -0400
committerNick Mathewson <nickm@torproject.org>2013-04-25 13:43:49 -0400
commit66dacfa2a58602d82e0413c8217ec38c9871d5cf (patch)
tree167986a180ff2c2e0935514f0cb2fb2b952152a2 /configure.ac
parent773b0a5d886534b057f5589814a284dcd85c73d8 (diff)
parent74d4c44cf2ce266471a2b98cc64f5502ae906019 (diff)
downloadlibevent-66dacfa2a58602d82e0413c8217ec38c9871d5cf.tar.gz
Merge remote-tracking branch 'origin/pr/36' into patches-2.0
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 09898d27..abe5e231 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6,7 +6,7 @@ dnl See LICENSE for copying information.
dnl
dnl Original version Dug Song <dugsong@monkey.org>
-AC_PREREQ(2.59c)
+AC_PREREQ(2.59)
AC_INIT(event.c)
AC_CONFIG_MACRO_DIR([m4])
@@ -35,10 +35,15 @@ esac
dnl Checks for programs.
AC_PROG_CC
AM_PROG_CC_C_O
-AC_PROG_SED
AC_PROG_INSTALL
AC_PROG_LN_S
-AC_PROG_MKDIR_P
+# AC_PROG_MKDIR_P - $(MKDIR_P) should be defined by AM_INIT_AUTOMAKE
+
+# AC_PROG_SED is only available in Autoconf >= 2.59b; workaround for older
+# versions
+ifdef([AC_PROG_SED], [AC_PROG_SED], [
+AC_CHECK_PROGS(SED, [gsed sed])
+])
AC_PROG_GCC_TRADITIONAL