summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2021-03-23 09:52:14 +0800
committerfanquake <fanquake@gmail.com>2021-03-23 09:52:14 +0800
commit8e6090d001943241f57efb7329130ec86ba1dcd3 (patch)
treefa61e88d552adae7674afca5f677a052fa343f7c /configure.ac
parent00b92f42b69af29a820b46049fd00be9cd3fb7d4 (diff)
downloadlibevent-8e6090d001943241f57efb7329130ec86ba1dcd3.tar.gz
build: use AC_CHECK_LIB over AC_HAVE_LIBRARY
AC_HAVE_LIBRARY is deprecated, see https://www.gnu.org/software/autoconf/manual/autoconf-2.70/html_node/Obsolete-Macros.html, and has been prior to Autoconf 2.67, which is the minimum required by the project. It's usage also causes warnings with newer versions of autoconf: ```bash configure.ac:319: warning: The macro `AC_HAVE_LIBRARY' is obsolete. configure.ac:319: You should run autoupdate. ``` `AC_HAVE_LIBRARY` was introduced in #969, although it's not clear why it was decided to revert to using an obselete macro.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a143224e..5489c080 100644
--- a/configure.ac
+++ b/configure.ac
@@ -316,7 +316,7 @@ AM_CONDITIONAL(BUILD_MIDIPIX, test x$midipix = xtrue)
AM_CONDITIONAL(BUILD_WITH_NO_UNDEFINED, test x$bwin32 = xtrue || test x$cygwin = xtrue || test x$midipix = xtrue)
if test x$bwin32 = xtrue; then
- AC_HAVE_LIBRARY([ws2_32])
+ AC_CHECK_LIB([ws2_32], [main])
fi
dnl Checks for typedefs, structures, and compiler characteristics.