summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAzat Khuzhin <azat@libevent.org>2020-08-29 01:15:20 +0300
committerAzat Khuzhin <azat@libevent.org>2020-08-29 01:15:20 +0300
commit972289f356102d22a23aac4a93fe42de845dd917 (patch)
tree5f5e1df6285826beacde24c2eb2a983b33137385 /configure.ac
parente3e7bb212ea17aa8a9d5a30163487342e6ebb350 (diff)
downloadlibevent-972289f356102d22a23aac4a93fe42de845dd917.tar.gz
Detect existence of pthread_mutexattr_setprotocol()
Fixes: #1084
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2599c225..a143224e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -786,6 +786,8 @@ if test x$bwin32 != xtrue && test "$enable_thread_support" != "no"; then
[AC_INCLUDES_DEFAULT()
#include <pthread.h> ]
)
+
+ AC_CHECK_FUNCS([pthread_mutexattr_setprotocol])
fi
AM_CONDITIONAL(THREADS, [test "$enable_thread_support" != "no"])
AM_CONDITIONAL(PTHREADS, [test "$have_pthreads" != "no" && test "$enable_thread_support" != "no"])