summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDmitry Ilyin <dima@doty.ru>2022-08-07 13:51:48 +0300
committerAzat Khuzhin <azat@libevent.org>2022-08-09 00:18:10 +0200
commit99fd68abde4a59b90148db733fc51a7256cbd320 (patch)
tree0d0a7a0a3a689950921ad4536adc0bbc0c0919f1 /configure.ac
parentb2aca3bc31f46e7ea2fe2ac826ce2d3e6235f513 (diff)
downloadlibevent-99fd68abde4a59b90148db733fc51a7256cbd320.tar.gz
Add check of mmap64 function and use it when available rather that mmap
There can be issues on 32-bit architectures to mmap 2+GiB file, and to make this portable between different version of glibc, mmap64 was prefered over _FILE_OFFSET_BITS
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f90f2105..0d7e098c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -272,7 +272,7 @@ dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_INLINE
dnl Checks for library functions.
-AC_CHECK_FUNCS([accept4 arc4random arc4random_buf arc4random_addrandom eventfd epoll_create1 fcntl getegid geteuid getifaddrs gettimeofday issetugid mach_absolute_time mmap nanosleep pipe pipe2 putenv sendfile setenv setrlimit sigaction signal strsignal strlcpy strsep strtok_r strtoll sysctl timerfd_create umask unsetenv usleep getrandom ])
+AC_CHECK_FUNCS([accept4 arc4random arc4random_buf arc4random_addrandom eventfd epoll_create1 fcntl getegid geteuid getifaddrs gettimeofday issetugid mach_absolute_time mmap nanosleep pipe pipe2 putenv sendfile setenv setrlimit sigaction signal strsignal strlcpy strsep strtok_r strtoll sysctl timerfd_create umask unsetenv usleep getrandom mmap64])
AS_IF([test "$bwin32" = "true"],
AC_CHECK_FUNCS(_gmtime64_s, , [AC_CHECK_FUNCS(_gmtime64)])