summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAzat Khuzhin <azat@libevent.org>2022-11-12 18:56:25 +0100
committerAzat Khuzhin <azat@libevent.org>2022-11-12 19:00:10 +0100
commit9e346936d47a3a461f8ebaedabb2975bef3babf5 (patch)
treecb5d3120bcca5cc602ae1b524ed76c6c212a6680 /configure.ac
parent72a4fe76fc3c0d541905cda765ec531e0d515d01 (diff)
downloadlibevent-9e346936d47a3a461f8ebaedabb2975bef3babf5.tar.gz
Ignore unknown pragmas
Since new compilers has new checks (like -Wdangling-pointer), and so to avoid extra checks in cmake/autotools, simply suppress if the pragma is unknown.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cc961692..286b06c6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -772,6 +772,9 @@ if test "$enable_gcc_warnings" != "no" && test "$GCC" = "yes"; then
dnl Disable unused-function warnings. These trigger for minheap-internal.h.
AX_CHECK_COMPILE_FLAG([-Wno-unused-function], [CFLAGS="$CFLAGS -Wno-unused-function"],[],[-Werror])
+ dnl Disable unknown pragmas warnings.
+ AX_CHECK_COMPILE_FLAG([-Wno-pragmas], [CFLAGS="$CFLAGS -Wno-pragmas"],[],[-Werror])
+
if test "$have_clang" = "yes"; then
case "$host_os" in
darwin*)