summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfanquake <fanquake@gmail.com>2020-06-28 18:40:26 +0800
committerfanquake <fanquake@gmail.com>2020-06-28 19:34:14 +0800
commite05ee6d3b533d62717e1d0be8a98e83ec5f4fe40 (patch)
tree3ea7449a7f1beb13e0d13e96082b47fad088e5fd /configure.ac
parent8ac10b6bf7f67444d6867889e4eabf1defb457fa (diff)
downloadlibevent-e05ee6d3b533d62717e1d0be8a98e83ec5f4fe40.tar.gz
build: consolidate darwin compile flag additions in configure
This is mostly move-only, apart from some changes to comments.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 6 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index 4e2a9855..1b647ed8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -62,16 +62,6 @@ if test "$GCC" = "yes" ; then
fi
fi
-dnl OS X Lion started deprecating the system openssl. Let's just disable
-dnl all deprecation warnings on OS X; but do so only for gcc...
-if test "$GCC" = "yes" ; then
- case "$host_os" in
- darwin*)
- CFLAGS="$CFLAGS -Wno-deprecated-declarations"
- ;;
- esac
-fi
-
AC_ARG_ENABLE(gcc-warnings,
AS_HELP_STRING(--disable-gcc-warnings, disable verbose warnings with GCC))
@@ -902,16 +892,17 @@ if test x$enable_gcc_warnings != xno && test "$GCC" = "yes"; then
fi
if test x$have_clang = xyes; then
- dnl Disable the unused-function warnings, because these trigger
- dnl for minheap-internal.h related code.
+ dnl Disable unused-function warnings. These trigger for minheap-internal.h.
CFLAGS="$CFLAGS -Wno-unused-function"
- dnl Clang on macosx emits warnings for each directory specified which
- dnl isn't "used" generating a lot of build noise (typically 3 warnings
- dnl per file
case "$host_os" in
darwin*)
+ dnl Clang on macOS emits warnings for each directory specified which
+ dnl isn't "used", generating a lot of build noise.
CFLAGS="$CFLAGS -Qunused-arguments"
+ dnl macOS Lion started deprecating the system OpenSSL. Let's just
+ dnl disable all deprecation warnings on macOS; but do so only for GCC.
+ CFLAGS="$CFLAGS -Wno-deprecated-declarations"
;;
esac
fi